Back to the Vavoom Forum Archives


Forum

windowsXP and progs!!!

Fri, 04 Feb 2005 23:45:38

gunrock

Okay now that i installed xp on my new comp the progs stopped compiling properly. it will create the progs dat file but it won't show any new changes. I have noticed that when you make changes to the VC.files and compile the progs dat file will get bigger in kilobyte size but for me and my vc file change it stays the same.
Sat, 05 Feb 2005 17:11:57

Firebrand

I remember someone posted an issue like this before, and Janis pointed him to a 32-bit version of the vcc compiler, that might help you out, could you repost the link to that version again Janis?
Mon, 07 Feb 2005 07:51:56

Janis Legzdinsh

Here it is.
Mon, 07 Feb 2005 14:29:14

CheapAlert

On a related note, think you could do a GUI version or frontend of some sort? Win FrikQCC 2.6 (from wiki.quakesrc.org) might be an inspiration <!-- s:P --><img src="{SMILIES_PATH}/icon_razz.gif" alt=":P" title="Razz" /><!-- s:P --> Maybe a VavoomC IDE based on Scintilla too? <!-- s;) --><img src="{SMILIES_PATH}/icon_wink.gif" alt=";)" title="Wink" /><!-- s;) -->
Mon, 07 Feb 2005 15:37:53

Janis Legzdinsh

Maybe one day, but for now KDevelop works fine for me.
Sat, 12 Feb 2005 02:06:47

gunrock

<!-- s:? --><img src="{SMILIES_PATH}/icon_confused.gif" alt=":?" title="Confused" /><!-- s:? --> Hmmmmm Janiz.....It will compile but still no changes to the clprogs.dat and cvprogs.dat files Here is the information i'm getting: C:\Program Files\Doom II for Windows 95\Vavoom\progs\doom2>vcc -I../common -Icom mon clprogs C:\Program Files\Doom II for Windows 95\Vavoom\progs\doom2>vcc -I../common -Icom mon svprogs
Sat, 12 Feb 2005 17:51:40

Firebrand

Are you updating them inside the wad0.wad file? also, are you sure you are giving the exact directory of your project to Vavoom? I don't know what else could be the problem there, you seem not to be getting any compile errors there... <!-- s:?: --><img src="{SMILIES_PATH}/icon_question.gif" alt=":?:" title="Question" /><!-- s:?: -->
Mon, 14 Feb 2005 07:52:44

Janis Legzdinsh

Try to delete .dat files and recompile. If compiller will create them that means it works fine.
Mon, 14 Feb 2005 20:54:33

gunrock

I deleted the dat file and compiled it as you said but still no changes i made show up in the wad. As i rememeber any changes in the vc.file increase the size of a prog.dat that's not happening in my case. And usally when i compile the progs.dat back in version 1.15 i would take them out of the doom2 progs folder and paste them into my custom game progs folder and they would work.
Mon, 14 Feb 2005 21:22:37

Firebrand

Once you delete the .dat files, do they appear again? If that's the case, then they are compiling withouth errors, if they don't appear, then it's a problem with the compiler. If they appear then move them to the wad0.wad file in your progs directory, if they don't appear then something is wrong with compilation of your progs.

Back to the Vavoom Forum Archives