Back to the Vavoom Forum Archives


Forum

Vavoom not working on Lucid Puppy Linux 5.2.5

Sat, 30 Jun 2012 16:38:08

quattj

I'm not an expert with that, but it sounds like since you did not install OpenGL, vavoom has nothing to draw the graphics with. It can use OpenGL or Direct 3D (at least in the Windows version). Since you have neither of these, you get a "No Drawer" error. Or so I assume <!-- s:csaw2: --><img src="{SMILIES_PATH}/csaw2.gif" alt=":csaw2:" title="Chainsaw 2" /><!-- s:csaw2: -->
Sat, 16 Jun 2012 23:23:52

kaeza

Hello. I'm a new user here. First of all, thanks for doing such a great port of Doom. I have downloaded the source archive for version 1.33, and compiled it on a bare-bones installation of Lucid Puppy Linux 5.2.5 (well... only installed Allegro 4.4.2 beforehand). The distro has no wxWidgets library by default (it can be installed viaa a package manager though), so I decided to omit the compilation of the launcher. Since also SDL is not installed, and OpenGL runs awfully slow on my graphics card, I disabled those parts of Vavoom too. Everything compiled, and installed OK, but when I run the game, it says "No drawers available" and exits. What could be the problem?
Sat, 30 Jun 2012 21:23:38

kaeza

Thanks for your reply. I have installed the OpenGL drivers for my card and now it works correctly. Sorry for bothering.

Back to the Vavoom Forum Archives