Back to the Vavoom Forum Archives


Forum

[Resolved] Compile Error

Thu, 07 Jul 2005 08:36:29

sanmadjack

I'm trying to compile under 64-bit Ubuntu, and it gives me morewarnings than I've ever seen in a compile (congrats, dude), and then stops saying this: source/gl_main.cpp: In member function `virtual void VOpenGLDrawer::SetupView(const refdef_t*)': source/gl_main.cpp:397: error: unrecognizable insn: (insn:HI 897 896 468 28 0x2a96c41ea0 (set (reg:SI 138) (plus:SI (mult:SI (reg:SI 138) (const_int 2 [0x2])) (const_int 4352 [0x1100]))) -1 (insn_list 896 (nil)) (nil)) source/gl_main.cpp:397: internal compiler error: in extract_insn, at recog.c: 2175 Please submit a full bug report, with preprocessed source if appropriate. See <URL:http://gcc.gnu.org/bugs.html> for instructions. For Debian GNU/Linux specific bug reporting instructions, see <URL:file:///usr/share/doc/gcc-3.3/README.Bugs>. make: *** [obj/gl_main.o] Error 1 I have no idea what this means, but keep up the good work. I'll just reboot and play this thing in windows for now.
Thu, 07 Jul 2005 17:25:04

Janis Legzdinsh

64-bit, whell it's prety sure it won't work as 64 bit application since a lot of code assumes 32 bit. I see that gcc crashed, that's something new. I can't see any reasin why it could crash there. What version of gcc do you use? Anyway, for start you can try to compile without OpenGL.
Thu, 07 Jul 2005 17:48:32

sanmadjack

I've got GCC 3.3, 3.4, and 4.0 installed, not sure which is the one being used to compile. I type in gcc --version and it said 3.3.3, so I guess that's the default. I disabled OpenGL and it compiled, btu upon running (after placing my strife WAD int he apropriate folder) adding strife1.wad adding voices.wad adding basev/strife/wad0.wad Selected SDL sound device open /dev/sequencer: No such file or directory Configured audio device for 2 channels, format 8010. Driver : alsa CD_Init: open of "/dev/cdrom" failed (123) Selected Software reaserizer Segmentation fault I compiled with and without SDL and the results were the same.
Fri, 08 Jul 2005 18:21:10

Janis Legzdinsh

As expected Vavoom doesn't work as 64 bit application. Instead you can try to compile it as 32 bit application. To do this edit main Makefile and all Makefiles in utilities subdirectories, search for gcc calls and everywhere add option -m32
Thu, 21 Jul 2005 04:19:03

sanmadjack

I changed all thos gcc commands and maked, and it ended with this: /usr/bin/ld: Warning: size of symbol `typeinfo for GLVisError' changed from 8 in obj/l_glvis.o to 16 in utils/glvis/libglvis.a(level.o) /usr/bin/ld: skipping incompatible /usr/lib/libGL.so when searching for -lGL /usr/bin/ld: skipping incompatible /usr/lib/gcc-lib/x86_64-linux/3.3.5/../../../../lib/libGL.so when searching for -lGL /usr/bin/ld: skipping incompatible /usr/lib/gcc-lib/x86_64-linux/3.3.5/../../../libGL.so when searching for -lGL /usr/bin/ld: skipping incompatible /usr/lib/../lib/libGL.so when searching for -lGL /usr/bin/ld: skipping incompatible /usr/bin/../lib/libGL.so when searching for -lGL /usr/bin/ld: skipping incompatible /usr/lib/libGL.so when searching for -lGL /usr/bin/ld: cannot find -lGL collect2: ld returned 1 exit status make: *** [Vavoom] Error 1 I'm assuming that it has something to do with attempting to link to my Gl libraries wich are fillled with too much 64-bit goodness for the compile to handle. Alas, am I going to be forced to compile this in a dreaded chroot? Such is the curse of the 64.
Thu, 21 Jul 2005 06:14:15

Janis Legzdinsh

/usr/bin/ld: Warning: size of symbol `typeinfo for GLVisError' changed from 8 in obj/l_glvis.o to 16 in utils/glvis/libglvis.a(level.o)
Run 'make clean' followed by 'make' to make sure everything gets rebuilt.
I'm assuming that it has something to do with attempting to link to my Gl libraries wich are fillled with too much 64-bit goodness for the compile to handle. Alas, am I going to be forced to compile this in a dreaded chroot? Such is the curse of the 64.
If your GL libraries are frm NVIDIA or ATI it's possible that they are not ready for compiling 32 bit apps. So you'll have to compile without OpenGL.
Fri, 22 Jul 2005 19:38:11

sanmadjack

It matters little now. I managed to compile it within a 32-bit chroot, and all is well now. Thanks for the help, but it seems my dream of a 64-bit Vavoom is no more.
Sun, 24 Jul 2005 09:46:48

Janis Legzdinsh

When I'll get a 64 bit system myself, I'll eventually port it, but till then there's little chance to be ported.

Back to the Vavoom Forum Archives