Back to the Vavoom Forum Archives


Forum

[Not a bug] Vavoom hates my laptop

Thu, 09 Sep 2004 03:35:03

CheapAlert

Can't start Vavoom95 v1.15 b2<br><br>Crashes right on startup:<br><br>Failed to initialize keyboard<br><br>Stack trace: StartupKeyboard <- IN_Init <- Host_Init<br><br><br><br>Even with all the stuff disabled, this still happens.<br><br>Compaq Presario 1277<br>AMD k6-2 433MHz<br>64MB RAM<br>Trident Cyberblade3d i7 8MB video<br>VIA on-board icky audio<br>10GB HD<br>Windows 98SE<br><br><br>In addition, the DOS version crashes:<br><br>
Exiting due to signal SIGILL<br>Invalid Opcode at eip=0001d262<br>eax=ffffffff ebx=001ef220 ecx=ffffffff edx=001d55b0 esi=001ef920 edi=00000000<br>ebp=ffaabfec esp=ffaabf94 program=C:\GAMES\VAV\VAVOOM.EXE<br>cs: sel=00a7  base=83da3000  limit=ffaabfff<br>ds: sel=00af  base=83da3000  limit=ffaabfff<br>es: sel=00af  base=83da3000  limit=ffaabfff<br>fs: sel=0087  base=0000a300  limit=0000ffff<br>gs: sel=00bf  base=00000000  limit=0010ffff<br>ss: sel=00af  base=83da3000  limit=ffaabfff<br>App stack: [ffaac000..ffa2c000]  Exceptn stack: [0030d06c..0030b12c]<br><br>Call frame traceback EIPs:<br>  0x0001d262<br>  0x0019d4e7<br><br><br><br>
Thu, 09 Sep 2004 16:44:38

Janis Legzdinsh

Strange, strange. It seams that Keyboard support in DirectX is not working properly. The input part needs DirectX 5, but it's recomended to have latest version. Also run dxdiag and see if keyboard device is working.
Thu, 09 Sep 2004 18:11:30

CheapAlert

I've got DX 9.0b on there.<br><br>No problems found in the input tab.<br><br>Apparently, Zdoom 2.0.63 (not 1.22) and all it's derivatives (ZdoomGL, Skulltag) crash on startup as well and "keyboard" is in the stack dump. So yeap, unusual keyboard problem.
Mon, 13 Sep 2004 07:17:02

Firebrand

It could be a problem with your keyboard drivers, you could try to look for an update.
Mon, 13 Sep 2004 17:50:57

CheapAlert

The keyboard doesn't even have a name or any identification, and i've installed the latest Synaptics touchpad drivers (17mb big, ouch) even though that's not related. Right now the M$ standard 102-key keyboard driver is used (the factory setting)
Thu, 07 Oct 2004 12:44:16

CheapAlert

<!-- m --><a class="postlink" href="http://forum.zdoom.org/viewtopic.php?t=2737">http://forum.zdoom.org/viewtopic.php?t=2737</a><!-- m --> It seems randy has a clue on this, could be right, my laptop has no game port <!-- s:( --><img src="{SMILIES_PATH}/icon_sad.gif" alt=":(" title="Sad" /><!-- s:( -->
Thu, 07 Oct 2004 12:54:46

Janis Legzdinsh

Strange, because in Vavoom it crashes while initializing keyboard. You can try to run Vavoom with -nojoy parameter, but I kinda doubt that it will help.
Tue, 19 Oct 2004 18:01:38

CheapAlert

Nopey, doesn't work still, same error. <!-- s:( --><img src="{SMILIES_PATH}/icon_sad.gif" alt=":(" title="Sad" /><!-- s:( --> EDIT: Just tried Zdoom 2.0.91 (Susan's Sister) with -nojoy, it seemed to work :O
Thu, 06 Apr 2006 23:11:34

Janis Legzdinsh

Anyway, it doesn't seen to be a bug in Vavoom.

Back to the Vavoom Forum Archives