Back to the Vavoom Forum Archives


Forum

[Not a bug] strat problems in Linux

Wed, 13 Mar 2002 05:02:39

Duke42

OK, I've compiled 1.11.2 without problems - except for some compiler warnings (gcc 2.96).<br>But Vavoom won't run. I downloaded the shareware-version of doom1 and placed doom1.wad in the directory. Startig with ./Vavoom I get:<br><br>adding doom1.wad<br>adding basev/doom/wad0.wad<br>adding basev/doom1/wad0.wad<br>Abgebrochen<br><br>(This is german locale: "cancelled")<br>gdb output:<br>(gdb) run<br>Starting program: /usr/local/games/Vavoom/./Vavoom <br>(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024 (LWP 9336)]<br>[New Thread 2049 (LWP 9341)]<br>Can't attach LWP 9341: Operation not permitted<br>(gdb) bt<br>#0  0x406ca851 in __linuxthreads_create_event () at events.c:26<br>#1  0x406c6711 in __pthread_initialize_manager () at pthread.c:589<br>#2  0x406c7168 in __pthread_create_2_1 (thread=0x4012f404, attr=0x0, start_routine=0x400f0604 <_unix_get_executable_name+464>, <br>    arg=0x0) at pthread.c:647<br>#3  0x400f0840 in _unix_get_executable_name () from /usr/local/lib/liballeg.so.4.0<br>#4  0x4011afe0 in system_xwin () from /usr/local/lib/liballeg.so.4.0<br>Cannot access memory at address 0x5857494e<br><br>So, what now?
Thu, 14 Mar 2002 01:45:14

Janis Legzdinsh

If you are running on Linux console, make sure that executable has root privilegies. Also try to use OpenGL, disable sound, etc.
Thu, 14 Mar 2002 06:32:12

Duke42

yepp, -NOMUSIC did the trick. It seems I can't get midi out of my sblive... oh well <!-- s;-) --><img src="{SMILIES_PATH}/icon_wink.gif" alt=";-)" title="Wink" /><!-- s;-) -->. Thank you!<br><br>Duke42.

Back to the Vavoom Forum Archives