Back to the Vavoom Forum Archives


Forum

[Not a bug] Sound Error, Please Help, can't

Mon, 11 Feb 2002 01:32:31

Morolinith

I keep getting this error:<br>Abnormal Program Termination<br><br>The Debug test is:<br>0x4000000 (64.000000 meg) allocated for zone, ZoneBase: 0x1EE0004<br>adding D:/Games/Doom/Doom.wad<br><br>ERROR: W_GetNumForName: sfxinfo not found!<br><br>What am I doing wrong? I would really like to try this program out but it gives the above error when I try to play any of the games. (top part of error depends on game but always adds the wad ok.<br><br>Thanks,<br>Moro
Tue, 12 Feb 2002 03:06:02

Janis Legzdinsh

Are you sure that you installed Vavoom in the same directory as the doom.wad and that this directory is the working directory?
Tue, 12 Feb 2002 05:50:30

Morolinith

In Heretic for example in my games.txt file<br>// Heretic<br>game basev/D:\Games\Vavoom\basev\heretic<br>iwad D:\Games\Vavoom\basev\heretic\heretic.wad<br>param -heretic<br>end<br><br>Loads the wad and sound buffers but still gives me that error about the sfxinfo. I opened the startup.vs file and I don't have an autoexec.cfg or config.cfg file anywhere. I tryed copying mine from c:\ to the vavoom folder but it didn't make any difference.<br><br>Any ideas on this?<br>Moro
Tue, 12 Feb 2002 06:04:41

quattj

I seee...<br>OK, the easiest thing for you to do is just re-install Vavoom (or extract the original games.txt from the archive file).  You shouldn't have to edit games.txt at all.  Leave it as it was.<br>So where you have<br><br>// Heretic <br>game basev/D:\Games\Vavoom\basev\heretic <br>iwad D:\Games\Vavoom\basev\heretic\heretic.wad <br>param -heretic <br>end <br> <br>it should just be<br><br>// Heretic<br>game basev/heretic<br>iwad heretic.wad<br>param -heretic<br>end<br><br>You will need to have Vavoom installed into your Heretic directory, or in a directory of it's own with the heretic.wad file copied into the vavoom directory.<br><br>The autoexec.cfg... don't worry about that.  You don't need it unless you want to do any special configuring of your games.  The config.cfg... delete the one you copied into your game folder.  Bad <!-- s:( --><img src="{SMILIES_PATH}/icon_sad.gif" alt=":(" title="Sad" /><!-- s:( -->  (Leave the one in your c:\ directory.  That one is for your computer, not for Vavoom)  By coping that one into your game folder, you just confuse the game.  The config.cfg it is looking for is created by the game the first time it runs correctly.<br><br>So, in a nutshell:<br><br>1. Install Vavoom.<br>2. Copy the main wad files (doom.wad, doom2.wad, heretic.wad, hexen.wad) into your vavoom folder.<br>3. Run vavoom.  <br>( If you're using the DOS version, you need to run asetup.exe in the vavoom folder to set up the Allegro drivers (used for sound and input) before you run Vavoom for the first time, or it will probably lock up your computer )<br><br>That's all you should need to do to get it going.  Later on if you need to you can disable 3D Sound or CD music or whatever, but it's best to just get it going first.<br><br>Good luck... Hope this helps    ;D
Wed, 13 Feb 2002 02:34:53

Janis Legzdinsh

If you want to have IWAD files in another directory, you can edit games.txt and change path to them, but do not change anything else. Here's example:<br><br>// Heretic<br>game basev/heretic<br>iwad d:/games/heretic/heretic.wad<br>param -heretic<br>end<br>
Wed, 13 Feb 2002 03:25:29

Morolinith

That worked Fine. Should of been obvious, I don't know what the hell I was thinking, sorry for the stupidity.<br><br>Moro

Back to the Vavoom Forum Archives