Back to the Vavoom Forum Archives


Forum

[Not a bug] Installation on Ubuntu 4.10

Wed, 09 Mar 2005 00:09:21

szerencsefia

Hopefully I'm gonna get some help to install this game onto Ubuntu. I have installed the follows: Compiler and tools: * GNU C++ Compiler Libraries: * zlib-1.2.1.1-3ubuntu * libpng3-1.2.5.0-7 * Allegro 4.0.3 * SDL 1.2.8 * OpenGL (nVIDIA) * OpenAL-0.2003020200-1.2 --- After: ./fixunix.sh make --- Result: VOpenGLDrawer::SetResolution(int, int, int)': source/gl_x.cpp:147: error: `XLOCK' undeclared (first use this function) source/gl_x.cpp:147: error: (Each undeclared identifier is reported only once for each function it appears in.) source/gl_x.cpp:153: error: `XUNLOCK' undeclared (first use this function) make: *** [obj/gl_x.o] Error 1 --- Any idea? Erno <!-- s:shock: --><img src="{SMILIES_PATH}/icon_eek.gif" alt=":shock:" title="Shocked" /><!-- s:shock: -->
Wed, 09 Mar 2005 13:21:35

Janis Legzdinsh

I checked Allegro headers and found that this can happen only if Allegro was build without X-Windows driver. If you installed X devel package after building Allegro, you must rebuild it.
Fri, 18 Mar 2005 08:10:05

Janis Legzdinsh

I assume I can close this.

Back to the Vavoom Forum Archives