Back to the Vavoom Forum Archives


Forum

[LINUX]Can't play soundfont with timidity++

Tue, 30 Dec 2008 18:14:43

Arm1nius

Hello, I have installed vavoom 1.29 and timidity++ is set with a soundfont that can be heard outside vavoom. When I run the game , it log "no instrument is map tone bank 0..." and the same for drumsets. So does vavoom able to play soundfont because all soundfont I tried to use don't work.
Wed, 31 Dec 2008 17:42:47

xranger60

Good that you brought this up. I was going to ask about this. Using different soundfonts with timidity in Ubuntu yielded me no music in Vavoom. But this problem is interesting, because Vavoom is not the only one that has this problem. Chocolate Doom, PrBoom, Doomsday, all of them had the same problem once I commented out the line in Timidity.cfg that sources freepats and inserted a reference to a soundfont I downloaded instead. Zdoom and Dosbox worked fine. Same result if I don't comment out freepats and still try to add a soundfont. Anybody know if this can be fixed?
Wed, 31 Dec 2008 19:48:23

Arm1nius

So impossible to know if it is a bad setting of timidity or those port that don't support this. <!-- s:( --><img src="{SMILIES_PATH}/icon_sad.gif" alt=":(" title="Sad" /><!-- s:( --> If someone know how to configure timidity properly...
Sat, 03 Jan 2009 09:28:33

Janis Legzdinsh

Currently Vavoom doesn't support soundfont. It can be added later.
Mon, 05 Jan 2009 09:55:36

Arm1nius

Thanks, that's what I wanted to know.
Sun, 11 Dec 2011 19:58:22

dugan

Adding soundfont support is probably easier now than when this thread was last updated. Vavoom uses SDL_mixer to play MIDI, and a current Mercurial checkout of SDL_mixer supports soundfonts. Details here: <!-- m --><a class="postlink" href="http://forums.libsdl.org/viewtopic.php?t=7092&sid=0b205331238f097f4d48193a5acac23b">http://forums.libsdl.org/viewtopic.php? ... 3a5acac23b</a><!-- m --> The procedure, for the end-user, is to: a) build SDL_mixer with FluidSynth support, b) set the SDL_SOUNDFONTS environment variable to the path to the soundfont(s) to be loaded, and c) start the game. This works with PrBoom and Doomsday. Trying it with Vavoom, however, gives me the following start-up message:
...
Found OpenGL 2.0 separate stencil methods
Found GL_ARB_depth_clamp...
Found GL_EXT_stencil_wrap...
Found GL_ARB_vertex_buffer_object...
Vertex buffer object extensions found.
Found GL_EXT_draw_range_elements...
Draw range elements extensions found.
fluidsynth: warning: Failed to pin the sample data to RAM; swapping is possible.
fluidsynth: error: Couldn't open the MIDI file

Back to the Vavoom Forum Archives