Back to the Vavoom Forum Archives


Forum

[Fixed] Vavoom and OpenAL

Tue, 13 Dec 2005 22:13:49

Deathlike2

Maybe it is just me, but there seems to be a problem with Vavoom's OpenAL. There is a problem with Vavoom and the OpenAL driver that is available at <!-- m --><a class="postlink" href="http://www.openal.org">http://www.openal.org</a><!-- m --> It seems to me that you are using an older version of OpenAL (the driver seems to have been copied from the Audigy drivers) which is very likely not compatible with any other hardware that has OpenAL support. If you reprogram your program properly to support the OpenAL driver released on that website (and perhaps including it with the program or give people a link to download it).. then you may not have to redo whatever MIDI support you were going to do. I tried to remove the OpenAL driver supplied by Vavoom and use the driver supplied from the OpenAL website and it did not work for some reason... This is why I think there is a problem with the OpenAL support. It seems to only rely on the OpenAL driver you've supplied which only supports the sound card it was made for... The OpenAL driver at the website I have listed "is supposed" to work with all sound cards with "correctly installed sound drivers"...
Tue, 13 Dec 2005 23:37:53

Firebrand

Is there anything that makes the upgrade necessary? I think the current OpenAL driver works nicely, besides Vavoom includes the DLL file necessary for it to work, so I don't see why it should be updated.
Wed, 14 Dec 2005 01:11:15

Deathlike2

Well, it's never seemed to work for me.. and I'm using an SB Live! Value..
Wed, 14 Dec 2005 18:44:54

Janis Legzdinsh

There is a problem with Vavoom and the OpenAL driver that is available at <!-- m --><a class="postlink" href="http://www.openal.org">http://www.openal.org</a><!-- m -->
I'll check that.
It seems to me that you are using an older version of OpenAL (the driver seems to have been copied from the Audigy drivers)
Yes, it's an older version, but it's not from Audigy (I never had it). It emulates OpenAL using DirectSound.
then you may not have to redo whatever MIDI support you were going to do.
How the hell is that going to fix problem with MIDI?
Thu, 15 Dec 2005 20:41:06

Deathlike2

How the hell is that going to fix problem with MIDI?
I thought the OpenAL support is for the the sound effects+MIDI.. am I wrong? When I've enabled the OpenAL feature.. I get sounds.. but I get absolutely no music (MIDI).. I thought that when you designed the audio with OpenAL in mind.. that when the music is rendered in OpenAL, it would sound normal than what is currently played w/o it. If I'm totally wrong on this, then I apologize. In any case, if the MIDI playing gets fixed.. that would be the most significant fix up to this point.
Fri, 16 Dec 2005 18:52:57

Janis Legzdinsh

I thought the OpenAL support is for the the sound effects+MIDI.. am I wrong?
Yes, you are wrong. OpenAL has nothing for MIDI. That's why I'm changing MIDI driver and adding TiMidity.
Sun, 19 Oct 2008 17:26:28

Janis Legzdinsh

Vavoom now uses latest version available from openal.org.

Back to the Vavoom Forum Archives