Back to the Vavoom Forum Archives


Forum

[Fixed] level change: fps drop, shadows change

Thu, 27 May 2010 16:47:53

appelzin3

(SVN 4256 and previous builds with new renderer) My gfx card doesn't support the new renderer so I have r_level_renderer 0. But there's now a fps drop when starting a new level after the first played level. Especially on areas with lights and torches. For example Doom2. If I freshstart Vavoom and warp to MAP29: > MAP MAP29 I've 60 fps and two torches at sight. If I now restart the level with the same same console command: > MAP MAP29 I've 8 fps! This slowdown happens with different wads I've tried. The first level runs fine, the next levels have slowdowns on areas having lights. The other thing is that the shadows from objects in front of the lights change their look at the same. Here's a short demo map (Doom2, MAP01) and two screenshots. The first one (60 fps) is after I just started MAP01, the second one (30 fps) is right after I've restarted the level ('MAP MAP01') Note how sharp the shadows are. Something is not right but is it just my system? There's no changes with the gfx setups, everything is as defult.
Sat, 29 May 2010 15:10:50

Firebrand

The advanced renderer uses totally different technique to generate shadows, so they won't look the same as in the old renderer, the shadows you are seeing are correct, but I've found a small bug with shadow calculations, notice these screenshots. The first shot (shot0000) show the start spot of the map, notice the shadow that light next to the skull column produces. Now check it out on the second shot (shot0001), it's not there... [spoiler:280r7dac][attachment=1:280r7dac]<!-- ia1 -->shot0000.png<!-- ia1 -->[/attachment:280r7dac][/spoiler:280r7dac] [spoiler:280r7dac][attachment=0:280r7dac]<!-- ia0 -->shot0001.png<!-- ia0 -->[/attachment:280r7dac][/spoiler:280r7dac]
Mon, 31 May 2010 21:16:39

Janis Legzdinsh

My gfx card doesn't support the new renderer
It seams to me that it does.
so I have r_level_renderer 0.
0 means auto detect
But there's now a fps drop when starting a new level after the first played level. Especially on areas with lights and torches. For example Doom2. If I freshstart Vavoom and warp to MAP29: > MAP MAP29 I've 60 fps and two torches at sight. If I now restart the level with the same same console command: > MAP MAP29 I've 8 fps! This slowdown happens with different wads I've tried. The first level runs fine, the next levels have slowdowns on areas having lights.
From what I tried it you start a map from command line or autoexec.cfg it selects regular renderer because graphics is not initialised yet, and second time it selects advanced. That's why there's the difference.
I've found a small bug with shadow calculations
Fixed.
Tue, 01 Jun 2010 04:53:40

b0rsuk

[quote="Janis Legzdinsh":oesmf3sx]
so I have r_level_renderer 0.
0 means auto detect Oh. I hope there is a way to turn it off ? I have a relatively good computer (C2D E6750, 2GB RAM, GeForce8800 GTX) but on some maps performance is very bad. By very bad I mean FPS around 30, sometimes even single digit. Examples of maps with very bad performance: Thunderpeak (Doom2), the recent Heretic wad from Doomworld news updates, Serpent Resurrection. Performance is stellar on stock maps and on those which are relatively conservative (such as anything in Alien Vendetta wad).
Tue, 01 Jun 2010 16:47:08

appelzin3

[quote="b0rsuk":2k4w7mi0] I hope there is a way to turn it off ? I have a relatively good computer (C2D E6750, 2GB RAM, GeForce8800 GTX) but on some maps performance is very bad. By very bad I mean FPS around 30, sometimes even single digit. Examples of maps with very bad performance: Thunderpeak (Doom2), the recent Heretic wad from Doomworld news updates, Serpent Resurrection. The latest r4286 version runs much faster on my system. Also switching vsync off helped. Thanks! BTW, Vavoom does not use the new renderer but the old one if I have 'r_level_renderer "0"' in config.cfg and I run Vavoom a command line which warps directly to the map: > vavoom.exe -iwaddir [...] -doom2 +skill 3 +map map01 -opengl (or copy that '+skill 3 +map map01' as other options parameters in VLaunch) But Vavoom starts to using the new renderer if: - that level (which started playing with the old renderer) ends and I progress to the next level. - I restart that level from the savegame - I warp to some level from the console ('MAP MAP01') - Or I run Vavoom with a basic command line: > vavoom.exe -iwaddir G:\doom -doom2 -opengl and start the game from the main menu (single player/new game/UV) or start the map from the console ('MAP MAP01').
Tue, 01 Jun 2010 17:12:25

Janis Legzdinsh

[quote="b0rsuk":razeyoon]I hope there is a way to turn it off ? The values of r_level_renderer are: 0 - auto-detect 1 - regular 2 - advanced As of starting maps from command line, auto-detect will select regular renderer because graphics haven't been started yet. There's no way around this.

Back to the Vavoom Forum Archives