Back to the Vavoom Forum Archives


Forum

[Fixed] Error loading saves!!!

Wed, 21 Jan 2004 04:26:24

szhukov

Random saved games (in doomII, heretic, hexen) cann't be loaded with crash: [color=Red:2702clkj]"Z_Malloc: failed on allocation of 39332 bytes \n Stack trace: Z_Malloc <- SV_LoadGame <- COMMAND Load <- Host_Frame"[/color:2702clkj]<br>OS: XP Pro; RAM: 384MB
Wed, 21 Jan 2004 16:40:04

Janis Legzdinsh

Try to use -minzone option. Maybe it will help, maybe not. It's a known problem and I'll try to fix it ASAP.
Wed, 21 Jan 2004 23:27:10

szhukov

[color=Red:wf8d5q4z]-minzone 800[/color:wf8d5q4z] and several other values has been tried. Result -  segmentation (see attached file) [img:wf8d5q4z]http://217.144.68.114/images/gluk.jpg[/img:wf8d5q4z]
Thu, 22 Jan 2004 16:44:18

Janis Legzdinsh

Like it was in another post. Will fix it immediately.
Fri, 23 Jan 2004 07:30:42

quattj

Yeay!<br><br>Janis, have I told you how cool you are sometimes?  ;D<br><br>I have vast knowledge of computers, yet I can't program to save my life.  I made a DOS-based game menu, and that's about as sophisticated as I get.  I can't imagine having someone say "Oh, every time I run your menu, my computer bursts into flames" and then be like "Oh, yeah, I can fix that.  OK, done!" <br><br>But that's pretty much what you do with vavoom.  You r00l!  ;)
Sat, 24 Jan 2004 02:46:49

Janis Legzdinsh

Thank you ;D!<br><br>BTW I already found the bug and fixed it.
Sat, 24 Jan 2004 05:19:23

quattj

See?  Exactly what I'm talking about  ;D<br><br>Oh, ummm... my Vavoom doesn't give me a million dollars any time I try to play a game.  It happens no matter what.  Any ideas?  ;D
Mon, 26 Jan 2004 16:51:33

Janis Legzdinsh

In current version loading a savegame with different -minzone setting most likely won't work.

Back to the Vavoom Forum Archives