Back to the Vavoom Forum Archives


Forum

[Fixed] 1.22 Ubuntu checking for png_read_image in -lpng...

Wed, 15 Nov 2006 17:07:30

roeleboel

Hello, I tried to install Vavoom 1.22 on Ubuntu 6.06.1 and I get this message when I run configure: checking png.h usability... yes checking png.h presence... yes checking for png.h... yes checking for png_read_image in -lpng... no configure: error: 'Vavoom requires libpng to compile' I have libpng installed, first via synaptic, then I tried after building libpng from source, but it doesn't work. Somebody a solution?
Wed, 15 Nov 2006 17:16:28

scen

Have you installed libpng12-dev package? If not, install it, and retry to build Vavoom.
Wed, 15 Nov 2006 22:48:10

Janis Legzdinsh

Also config.log will help.
Thu, 16 Nov 2006 15:41:46

roeleboel

Scen, I have libpng12-dev installed. Janis, here my config.log Regards, Roel
Thu, 16 Nov 2006 15:47:06

roeleboel

Second try for the attachement:
Thu, 16 Nov 2006 17:50:45

Janis Legzdinsh

It fails because OpenGL library cannot be found (must add a check for this). Either install it or use --without-opengl configure option.
Wed, 23 May 2007 18:26:58

Janis Legzdinsh

Added a check, this can be closed now.

Back to the Vavoom Forum Archives