Back to the Vavoom Forum Archives


Forum

[Fixed] [SVN] Segfault before map start

Tue, 13 Mar 2007 12:57:50

scen

Hi again <!-- s:P --><img src="{SMILIES_PATH}/icon_razz.gif" alt=":P" title="Razz" /><!-- s:P --> , the current SVN code (rev.2061) does a segfault when i try to start a map (tested with Doom E1M1 and Heretic E1M1 , with a clean configuration, rm -frv ~/.vavoom && vavoom -<game> -opengl). Here's a backtrace:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 47030771249808 (LWP 29955)]
0x000000000052d90d in Z_Free (ptr=0x7fff78bd3580, FileName=0x56a1da "message.cpp", LineNumber=78) at zone.cpp:488
488     in zone.cpp
(gdb) bt
#0  0x000000000052d90d in Z_Free (ptr=0x7fff78bd3580, FileName=0x56a1da "message.cpp", LineNumber=78) at zone.cpp:488
#1  0x0000000000460f90 in VMessageOut::Free (this=0x7fff78bd3560) at message.cpp:78
#2  0x00000000004f8d81 in SV_SendNop (client=0x93abac) at message.h:92
#3  0x00000000004f90d5 in SV_SendClientDatagram () at sv_main.cpp:1648
#4  0x00000000004f91d9 in SV_SendClientMessages () at sv_main.cpp:1745
#5  0x00000000004face3 in ServerFrame (realtics=1) at sv_main.cpp:3393
#6  0x000000000045093b in Host_Frame () at host.cpp:384
#7  0x00000000005468d5 in main (argc=<value optimized out>, argv=<value optimized out>) at sys_sdl.cpp:675
#8  0x00002ac633427374 in __libc_start_main () from /lib/libc.so.6
#9  0x0000000000407199 in _start ()
I'm running Gentoo Linux AMD64 + GCC 4.1.1; Vavoom compiled with SDL backend. If you need further informations, give me a call <!-- s:wink: --><img src="{SMILIES_PATH}/icon_wink.gif" alt=":wink:" title="Wink" /><!-- s:wink: -->
Wed, 14 Mar 2007 18:40:38

scen

Uhm, this issue seems to be fixed in rev.2064 <!-- s8) --><img src="{SMILIES_PATH}/icon_cool.gif" alt="8)" title="Cool" /><!-- s8) --> Close the bug if you want! <!-- s:P --><img src="{SMILIES_PATH}/icon_razz.gif" alt=":P" title="Razz" /><!-- s:P -->

Back to the Vavoom Forum Archives