Back to the Vavoom Forum Archives


Forum

[Fixed][Vavoom SVN4353] [Arch Linux 64Bit] glVis Problems

Wed, 22 Dec 2010 16:54:34

zico

Hey guys, Long time I had no time to play but now I wanted to play some Heretic again. I noticed that in some big battles my FPS go down a loooong way (180FPS down to 40FPS on a 3Ghz CPU and a NVidia GT240). So I wanted to run glVis on my WADs. However no matter which WAD I try I get the following erros:
[zico@stella ~/.vavoom]$ ./glvis doom2.wad
W_GetNumForName: GL_MAP01 not found!
[zico@stella ~/.vavoom]$ ./glvis heretic.wad
W_GetNumForName: GL_E1M1 not found!
[zico@stella ~/.vavoom]$ ./glvis hexen.wad
W_GetNumForName: GL_MAP01 not found!
[zico@stella ~/.vavoom]$ 
Same happens if I run glVis from inside the console of vavoom itself. I also tried glVis 1.6 but the results to this are the same as I had some years ago: <!-- l --><a class="postlink-local" href="http://www.vavoom-engine.com/forums/viewtopic.php?f=6&t=682&p=3531&hilit=glvis#p3531">viewtopic.php?f=6&t=682&p=3531&hilit=glvis#p3531</a><!-- l --> Is there some way I can optimize my WADs to get a bit more performance? Or are there some other hints how I can speed up the game? Best regards and a Merry Christmas, Christian
Wed, 22 Dec 2010 20:33:45

Firebrand

Before running glVIS, you should build GLnodes first using glBSP, you can get it from here: [url:1z7qtgyb]http://glbsp.sourceforge.net/
Thu, 23 Dec 2010 10:08:07

zico

Hello Firebrand. Thanks for your support - with glBSP before it now works fine. I wasn't aware I need to do that first. However it doe snot seem to help much as shown in my attached screenshot of Heretic E1M3 - The Cathedral (just opened the yellow door). I dunno what I do wrong here - I also went (after this screenshot) to the VIDEO OPTIONS screen and put all options to OFF (also putting filtering to NEAREST). It did not seem to even get me one single FPS more... I'm not really an FPS whore but 24 actually makes the game slow (I think this is related to the original tick value of 35? Correct me if I'm wrong - I don't know the engine too well). And what also is interesting me is why this happens at all. Not only to solve it but the actual reason. I can imagine the game needs a bit more performance than in good old 1996, but this seems a bit overload... so I am interested to learn about the nature of this problem as well. EDIT: I could solve the FPS problem by setting
gl_ext_shaders "0"
Now I ask myself why this is, what the shaders are used for and why they cause such a massive slowdown on my card (GT240). I play the games in most "Vanilla style" - no new models or HighRes textures.
Thu, 23 Dec 2010 19:09:39

Janis Legzdinsh

With advanced renderer it might run slower. Disabling shaders effectively forces regular renderer to be used.
Thu, 23 Dec 2010 22:57:05

zico

I know I pretty much play a developers version here so probably it's too early for such suggestions but I want to bring it up: Shouldn't there be a menu option to disable shaders? I must say playing "Vanilla Heretic" - only with some filtering and some other options I set in the Video Options I cannot notice any difference between shaders on/off. Only differenc ebeing that in this screenshot posted above I now get above 350FPS and they hardly get below it (can finally play with VSync again). So for me this would definately be worth an option in case the new renderer would not become a requirement soon (which I don't hope as I would need to upgrade my PC for this then and had no chance to play Vavoom on my eeePC anymore).
Fri, 11 Feb 2011 12:33:29

Firebrand

The option has been added now, select the regular renderer in the advanced video menu options. I'm closing this one now.

Back to the Vavoom Forum Archives