Back to the Vavoom Forum Archives


Forum

[1.27] Linux + ati-drivers + OpenGL = no cross crosshair

Sun, 06 Apr 2008 21:50:54

mnk

For some reason, on Linux with ati-drivers, using SDL OpenGL rasteriser cross crosshair fails to be displayed. With SDL software rasteriser it works, though. First, cross - software [attachment=2:xbcns0jo]<!-- ia2 -->shot0001.png<!-- ia2 -->[/attachment:xbcns0jo] Now cross - OpenGL (notice lack of it) [attachment=1:xbcns0jo]<!-- ia1 -->shot0006x.png<!-- ia1 -->[/attachment:xbcns0jo] And (for reference) angle - OpenGL [attachment=0:xbcns0jo]<!-- ia0 -->shot0005x.png<!-- ia0 -->[/attachment:xbcns0jo] OpenGL shots are scaled to 75%, cause files were too big. Oh, and if somebody has any doubts, it affects all of the games, not only Hexen.
Fri, 25 Apr 2008 16:09:05

mnk

Well, it looks like for some reason vavoom/basev/*/graphics/croshai1.lmp can't be processed correctly. And it's the file itself, cause if I swap i.e. croshai1.lmp with croshai3.lmp, it's still the cross that fails to be displayed. But why does it happen only for OpenGL ?
Fri, 25 Apr 2008 17:45:18

Janis Legzdinsh

It looks like it happens only on low screen resolutions. On higher ones it works fine.
Fri, 25 Apr 2008 18:10:37

mnk

Well, yes, it seems to affect 640x480 and 800x600 only.
Tue, 14 Oct 2008 09:03:24

mnk

I think it's fixed now (I'm not sure when did this happen, in the recent svn (r3813) or before, I haven't been using vavoom actively for a while).

Back to the Vavoom Forum Archives