Back to the Vavoom Forum Archives


Forum

[Not Vavoom]Vavoom 1.3 Heretic Music Volume

Wed, 23 Dec 2009 04:47:52

chessla

While the graphics are great, I have had no luck in being able to control the music volume. I've tried everything in the launcher and the in-game sound-options and the music volume just doesn't work. The CD AUDIO and EXTERNAL AUDIO only seem to turn the music on or off but have no effect on the in-game sound volume adjustment. I have an older system (SBLIVE! sound card with the latest drivers) but, I have Win XP SP2 and have not had problems before.
Wed, 23 Dec 2009 17:06:14

Firebrand

You are talking about the MIDI music or MP3 music? If you are talking about MIDI music, some drivers have different ways of setting that up, you can try adjusting the volume from the windows mixer, it should help a bit.
Thu, 24 Dec 2009 04:19:39

chessla

Thanks for your reply. The source of the music is from the Heretic WAD alone. There isn't any CD music source or external audio. I've tried muting the different (MIDI, MP3, etc.) sound sources, however, aside from being able to turn the music source off and on, I still cannot change the volume in-game. Adjusting the different source volumes in the WINXP volume advanced menu doesn't make any difference. I'm running Vavoom 1.3 and, from my bug report search, I can see that there have been volume problems before. This seems like a basic engine function. If I was trying to actually load music from a CD and there were CD device problems, that would be understandable, however, I am playing the game from the original WAD alone. Does anybody else have this problem?
Fri, 25 Dec 2009 04:06:07

chessla

As a reply to others who may have viewed this post, Firebrand was on the right track, and I thank him. While I turned off the music outside of Vavoom with the WINXP MIDI mute, I didn't experiment with the volume for this slider and, in fact, it does work. The trick of it is to get the MIDI volume balanced with the in-game sound volume and then the overall sound balanced, as well. A mean trick, to be sure, but I think I am OK. Of course, if the in-game music volume worked, no gymnastics would be needed - but, there you go.
Sat, 12 Jun 2010 14:49:08

Firebrand

This isn't a bug with Vavoom, but a problem in the way MIDI is implemented in Windows... you can avoid this problem by using Timidity for music output.

Back to the Vavoom Forum Archives