Back to the Vavoom Forum Archives


Forum

[Not a bug] Player keeps running forward error

Tue, 05 Aug 2003 03:31:02

Komet302

Has anyone else encountered this problem, everytime I start a new game useing Vavoom 115 and Doom 2 the player keeps moving forward even when I am not touching any keys. The key bindings are fine, the game ran well Yesterday, but this seems to be a re-occuring problem that has somehow corrected itself in the past for me. What is the real cause of this problem? Is it some kind of a bug in Vavoom? ???
Wed, 06 Aug 2003 16:27:07

Janis Legzdinsh

Really strange, never heard of such problem. If it will happen to me, I will fix it.
Wed, 06 Aug 2003 20:14:59

moose

I've had the same thing happen to me years ago in one of the Doom games, but that was just normal Dos doom, no port.<br><br>Do you have a joystick or other similer hardware on your PC, if so try unpluging it or disabling it in Vavoom. I think that was what my problem was, then again maybe not.
Thu, 07 Aug 2003 03:19:27

Komet302

Never would have guessed it was the joystick, but it seems to have done the trick. Thanks Moose.
Thu, 07 Aug 2003 06:21:56

moose

No problem.
Sat, 16 Aug 2003 11:37:55

Giomancer

IIRC, the stems from the calibration of the joystick on program startup. If the stick is not centered on startup but then returns to the normal, centered position, the program will read that as constant input to, say, go forward.
Mon, 18 Aug 2003 16:50:00

Janis Legzdinsh

It may be like this in DOS where joystick is calibrated at startup, but I don't think that it's like this in Windows and DirectX.

Back to the Vavoom Forum Archives