Back to the Vavoom Forum Archives


Forum

[Fixed] New cmake - new problem

Sat, 14 Nov 2009 23:16:02

mnk

With cmake 2.8.0, vavoom build aborts with errors at vlaunch. The problem is that now wxWidgets_DEFINITIONS are stripped of '-D' prefixes. Changing the obvious two lines in that CMakeFiles.txt to include(${wxWidgets_USE_FILE}) makes things work again. BTW, how about a little fix to _FORTIFY_SOURCE induced warnings ? IIRC, there are about two groups of "missing format string for printf" and one instance of "%06ld" when "unsigned int provided".
Tue, 17 Nov 2009 17:50:12

Janis Legzdinsh

Fixed.

Back to the Vavoom Forum Archives